Rendszerkövetelmények

Operációs rendszer: Linux-kernel 2.6 vagy újabb

Processzor: Intel Pentium vagy újabb

Memória: 32 MB vagy több

Telepítéshez szükséges lemezterület: kevesebb, mint 5 MB

Az AIDA64 teljes mértékben gyártófüggetlen, és minden PC-vel kompatibilis. Az elérhető funkciók szempontjából annak nincs jelentősége, hogy a szoftver szerver- vagy kliens-operációsrendszeren fut.

A programhoz szükséges egyéb követelmények:

  • lshw programcsomag, legalább B.02.16 verzió
  • libc6 könyvtárak (ajánlott)
  • root jog a futtatáshoz (ajánlott)
  • iconv csomag (nyelvfüggő)

A program teljes értékű működéséhez root jogosultság szükséges. Csökkentett jogosultságokkal a program nem fér hozzá a hardverinformációk és rendszertulajdonságok nagy részéhez, így az általa készített riport nem fog részletes információkat tartalmazni.

A program statikus verziója tartalmazza a szükséges libc6 könyvtárak nagy részét, de használata csak olyan szervereken javasolt, ahol nem megoldható ennek telepítése.